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End User Licence Agreement

Software Licence Agreement for Resound

1. GRANT OF LICENCE: Subject to the terms below, Loomer hereby grants you a non-
exclusive, non-transferable licence to install and to use Resound ('Software'). Under this 
licence, you may: (i) install and use the Software for your personal, internal use (ii) copy the 
Software for back-up or archival purposes; (iii) use an unregistered or evaluation version of 
the Software for evaluation purposes only. (iv) You may not distribute the software to others 
without first obtaining the required licences, where applicable. Whether you are licensing the 
Software as an individual or on behalf of an entity, you may not: (i) reverse engineer, 
decompile, or disassemble the Software or attempt to discover the source code; (ii) modify, 
or create derivative works based upon, the Software in whole or in part without the express 
written consent of Loomer; (iii) distribute copies of the Software; (iv) remove any proprietary 
notices or labels on the Software; (v) resell, lease, rent, transfer, sublicense, or otherwise 
transfer rights to the Software; By installing, copying, or using the Software, you (either on 
behalf of yourself as an individual or on behalf of an entity as its authorized representative) 
agree to all the terms of this End User Licence Agreement ('Agreement') regarding your use 
of the software. If you do not agree with all the terms of this Agreement, you may not use the 
Software.

2. RESOUND: You acknowledge that no title to the intellectual property in the Software is 
transferred to you. Title, ownership, rights, and intellectual property rights in and to the 
Software shall remain that of Loomer . The Software is protected by copyright laws and 
international treaty provisions. 

3. DISCLAIMER OF WARRANTY: You agree that Loomer has made no express warranties, 
oral or written, to you regarding the product and that the products are being provided to you 
'as is' without warranty of any kind. Loomer disclaims any and all other warranties, whether 
expressed, implied, or statutory. Loomer shall not be liable for indirect, incident, special, 
cover, reliance, or consequential damages resulting from the user of this product.

4. LIMITATION OF LIABILITY: You use this program solely at your own risk. In no event shall 
Loomer be liable to you for any damage, including but not limited to any loss, or other 
incidental, indirect or consequential damages of any kind arising out of the use of the 
software, even if Loomer has been advised of the possibility of such damages. In no event 
will Loomer be liable for any claim, whether in contract, tort, or any other theory of liability, 
exceed the cost of the software. This limitation shall apply to claims of personal injury to the 
extent permitted by law.

5. TERMINATION: This Agreement shall terminate automatically if you fail to comply with the 
limitations described in this Agreement. No notice shall be required to effectuate such 
termination. Upon termination, you must remove and destroy all copies of the Software. 

End User Licence Agreement
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6. MISCELLANEOUS: In the event of invalidity of any provision of this Agreement, the parties 
agree that such invalidity shall not affect the validity of the remaining portions of this 
Agreement. You agree that this is the entire agreement between you and Loomer, which 
supersedes any prior agreement, whether written or oral, and all other communications 
between Loomer and you relating to the subject matter of this Agreement. 

Reservation of rights.  
'VST' is a trademark of Steinberg Soft - und Hardware GmbH. All other trademarks are the 
property of their respective owners.
All rights not expressly granted in this Agreement are reserved by Loomer.

End User Licence Agreement
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Credits

Development Credits 

Resound © 2009 Loomer

Developed by	 Loomer
Interface by 	 	 Kevin Barry

Tested by	 	 Clifton Cameron
	 	 	 kuniklo
	 	 	 Scott Simons (rexlapin)
	 	 	 taoyoyo

VST PlugIn Technology by Steinberg Media Technologies GmbH. This software is based in 
part on libpng, zlib, and JUCE.

Credits
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Requirements

Mac OS X requirements

• Requires Mac OS X v. 10.4 or later
• Intel x86 based processor 1.0Ghz, or above, with SSE

or
• PPC based processor 1.0Ghz, or above
• 512 MB RAM

Windows requirements

• Windows XP or Windows Vista, or above
• Intel x86 based processor 1.0Ghz, or above, with SSE
• 512 MB RAM

Linux requirements

• Intel x86 based processor 1.0Ghz, or above, with SSE
• 512 MB RAM

The following shared object libraries are required:

• libfreetype
• libasound
• libjack
• libXinerama

Requirements
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Resound Overview

What is Resound?

Resound is a software audio delay effect processor that emulates the sound and operation of 
vintage magnetic-tape echo units. Whilst not a direct copy of any one particular model, it 
takes features from several of the classic delay devices, and unites them into a convincing 
and pleasingly retro sounding effect. 

Resound not only subtly models the characteristic mechanical noise present in hardware 
magnetic-tape units, but also allows the noise to be controlled; from gentle warmth and 
distortion, to noisy, gritty, and unstable. The sound can be shaped further using the moveable 
highpass filter. And with feedback set beyond a certain intensity, Resound is even capable of 
self-oscillation.

Resound's echoes can either be synced to the host tempo (expressing delay times as 
musical subdivisions of a beat, each echo will be exactly in time with the host) or in free-time 
mode (allowing any delay time, up to 2 seconds.) The reverse mode adds further flexibility: by 
playing each delay backwards, Resound can produce unique effects beyond what hardware 
magnetic-tape units are capable of. 

True independent stereo processing means that left and right channel separation is 
preserved. Resound is also capable or running in mono, or even mono to stereo. 

With optimized audio algorithms that won't overload your processor, rock-solid stability, and 
easy integration with any MIDI hardware controller, Resound is ideal for live work.
With a simple and intuitive interface, flexible Bank and Program management, and total 
parameter automation, Resound fits right into your studio environment.

Plug-in vs Standalone

Depending upon your individual studio setup, Resound can either be used as a plug-in 
component of a host application, or as a standalone application requiring no other 
dependencies. Generally, by using the host application's routing flexibility, running as a plug-
in allows easier integration with existing plug-in effects and instruments. If this integration is 
not required, the standalone version, without the extra layer of complexity added by the host 
consuming resources, performs slightly better. 

Bank and Program information, as well as MIDI Mapping assignments, are identical in both 
standalone and plug-in versions. This means any sounds created in one format can be 
opened in the other. 

Resound Overview
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Resound formats

For the Mac, the following formats are provided:

• Standalone Application
• Audio Unit (AU) Plug-In
• VST Plug-in
• RTAS Plug-in

These formats are available for Windows PC:

• Standalone Application
• VST Plug-in
• RTAS Plug-in

Linux have the following formats:

• Standalone Application
• VST Plug-in

Resound Overview
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Supported channel configurations

For maximum flexibility, Resound can be used in several possible input and output channel 
configurations. Resound is a true stereo effect: left and right channel separation is preserved. 
The following configurations are possible:

• mono to mono (1 input, 1 output)
• mono to stereo (1 input, 2 outputs)
• stereo to stereo (2 inputs, 2 outputs)

Note that some host applications may not support one or more of these configurations; 
consult your host's documentation for further details.

Resound Overview
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Installation and Registration

Mac OS X installation

1. Start the installation process by double-clicking the Resound installer application.
2. Read the introduction screen dialog text. Press Continue when you are ready to 

proceed.
3. Read the Licence Agreement. Click Continue, then Agree to confirm you have read and 

agree to the licence terms.
4. Select a destination volume into which to install Resound, and then click Continue. 
5. From the list of installable components, uncheck any formats that you do not wish to 

install. Click Continue to proceed.
6. To complete the installation, press Install. 

The components are, by default, installed into the following directories:

• VST plug-in into /Library/Audio/Plug-Ins/VST
• Audio Unit plug-in into /Library/Audio/Plug-Ins/Components
• RTAS plug-in into /Library/Application Support/Digidesign/Plug-Ins
• Standalone application into /Applications
• Documentation into /Library/Documentation
• Default Bank into /Library/Application Support 

Windows installation

1. Start the installation process by double-clicking the Resound installer application, 
Setup.exe. 

2. Read the welcome screen dialog text. Press Next when you are ready to continue.
3. Read the Licence Agreement. Click I Agree to confirm that you have read and agree to it.
4. From the list of installable components, uncheck any formats that you do not wish to 

install. Click Next to continue. 
5. If you have chosen to include the VST plug-in format, select the directory into which it will 

install. Click Next to continue.
6. Select a directory into which the common files will install. The user documentation, default 

Bank, and the Standalone application (if selected in the the list of components), will be 
placed in this location. To complete the installation, press Install.  

Unless any other directories are selected during the installation, the components are installed 
into the following directories:

• VST plug-in into the VST plug-ins folder, which is, unless configured otherwise, 
C:\Program Files\Steinberg\VSTPlugins\

• RTAS plug-in into C:\Program Files\Common Files\Digidesign\DAE\Plug-Ins\
• Standalone application, documentation and default Bank into C:\Program Files\Loomer

\Resound

Installation and Registration
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Linux installation

Resound for Linux is distributed as a standard Linux tarball. To install, extract the package 
using any unarchiving utility; the following command-line invocation will suffice:

 tar xzvf Resound.tar.gz 

If you have a Linux VST host and have configured your VST Path, the VST plug-in can be 
moved into the required directory with the following commands:

 cd Resound
 mv ResoundVST.so $VST_PATH

Without the VST Path configured, you will need to ensure that your host uses the Resound 
directory when searching for VSTs; consult your host's documentation for information on how 
to do this.

Resound requires the following shared object libraries to be installed:

• libfreetype
• libasound
• libjack
• libXinerama

Without these libraries installed, the application will not launch. Install the libraries using your 
distribution's particular package management system, such as apt-get; consult your Linux 
distribution documentation for more information.

Product registration

Having installed Resound, it will run in evaluation mode with the following limitations:

• User created Program and Bank configurations can be saved, but not loaded.
• Output will be periodically interrupted, approximately every 20 seconds, by a short moment 

of silence.

These limitations can be removed by purchasing a licence and registering your licence 
information into the product. Note that registering Resound on a particular machine will 
remove the evaluation limitations for all Resound plug-in formats installed on this machine; 
you don't need to individually register all plug-in formats. Licence information will be in the 
form of a user name and licence key. 

Installation and Registration
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To purchase a Resound licence:

1. Launch Resound. This can be either the standalone application, or as a plug-in.
2. From the Options menu, choose Purchase Resound Licence. This will launch the 

shop website, from where a Resound Licence can be purchased by clicking Add To 
Cart, followed by Checkout. Follow the on-screen prompts to enter your payment 
details and confirm your purchase.

3. Once you have purchased Resound, you will receive your licence key information via 
email. It is important to keep this information safe because you will require the licence key 
if you ever need to reinstall and re-register Resound. 

To register your copy of Resound:

1. Choose Enter Resound Licence from the Options menu.
2. Enter your name in the Name field. This must match exactly the name that was used to 

purchase your Resound licence, including capitalization of letters.
3. Enter your licence key in the Licence Key field. This must match exactly the licence that 

you received when you purchased Resound, including any hyphens.
4. Press OK to confirm that your name and corresponding licence key have been entered. 

You will be informed that the application must be restarted in order for registration 
changes to take effect. If you are currently running the standalone application, close and 
relaunch it. If Resound is currently running as a plug-in, remove it from the host and add a 
new instance of it.

5. Resound should now be registered. If the label on the bottom of the interface still reads 
Unregistered Evaluation, you must have entered the licence information incorrectly. Go 
back to step 1, paying careful attention that the name and licence key entered match 
exactly the licence information in the registration email.

Installation and Registration
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Audio and MIDI Configuration

Setup Audio and MIDI

When running Resound as a Standalone application, you will need to setup your audio and 
MIDI interfaces. Note that when running as a plug-in, audio and MIDI routing is provided by 
the hosting application; consult the host's documentation for details. To open the Audio & 
MIDI Configuration dialog, select Audio & MIDI Configuration under the Options menu. 

The following dialog will be displayed:

From this dialog, the following details of your Audio and MIDI setup can be configured:

• Audio Device. Select the Audio Device you want to use from the list of available devices. 
Certain devices tend to perform better than others, so if multiple devices are available, you 
should favour: on Mac, using Core Audio; on Windows, using ASIO; on Linux, using JACK.

• Sample Rate. The Sample Rate dictates the overall quality of the audio output. Using a  
lower Sample Rate will reduce the presence of high-frequency components. Higher Sample 
Rates should therefore be preferred. However, be aware that the CPU Usage is directly 
proportional to the Sample Rate. A good compromise between quality and CPU Usage is 
44100Hz, which is the Sample Rate of CD audio. Select the Sample Rate you require from 
the available list.

Audio and MIDI Configuration
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• Audio Buffer Size. The Audio Buffer Size governs latency; a smaller buffer means that 
Resound will respond more quickly to MIDI messages and Parameter changes. However, a 
smaller Audio Buffer Size will require more CPU Usage. Select the required Audio Buffer 
Size from the available list. Using too small of an Audio Buffer can overload your computer 
to the extent that audible clicks are heard. In this case, increase the Audio Buffer Size until 
clicks are no longer present..

• MIDI Inputs. Check any MIDI Input devices that you want to use with Resound. 

Audio and MIDI Configuration
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Program Management

Parameters, Programs and Bank

You can modify the audio output that Resound produces by setting the value of Parameters. 
Each Parameter, such as Delay Time, Feedback, or Highpass, will affect a specific element of 
the sound. The state of all Parameters are collectively called a Program. Programs are given a 
suitable name, displayed in the Menu Bar, to describe the sound they produce. 

Programs are grouped together into a Bank. You can only load a single Bank at a time. 
Although there is no requirement or limitation on how Programs are grouped, it is often useful 
to collect related Programs together, for example: a Bank of percussion sounds, a Bank 
containing sounds required to perform a specific set-list. 

Selecting Programs within a Bank

There are several ways of selecting a Program within a Bank:

• Menu Bar Previous and Next Controls. If you wish to browse quickly through all the 
Programs within a Bank, you can do so using the the Previous and Next controls. 

• Program Select Control. The Program Select Control will display a list of all programs 
contained  within a Bank. The required program can be selected from this list.  

• Program Change MIDI Messages. You can change programs by using MIDI Program 
Change commands. This requires a MIDI keyboard or a control surface with the ability to 
send MIDI Program Change commands; consult your controller’s documentation for details. 
If using Resound as a plug-in, this functionality is dependent upon the host correctly 
forwarding MIDI messages to the plug-in; check the documentation provided with your host 
for details.

• Host Application Program Management. If Resound is being used as a plug-in, the host 
may provide a mechanism to change the currently selected Program. The operation of this 
is entirely host dependent, and varies greatly from host to host; check the documentation 
provided with your host for details

Program Management
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File Management

If you wish to keep any changes to a Program, it will need to be stored in the current Bank. A 
program that needs storing is marked by an asterisk (*) suffix beside its name. Any changes 
will be lost if you change the currently selected Program without first storing it. The steps 
required to store a Program depend upon where you want to save it:

• To store the Program changes over the current version of itself in the bank:

1. Click Store. Notice that the asterisk disappears, indicating that the Program no 
longer has any outstanding changes that require storing.

• To store the Program changes to a different position in the Bank:

1. Click Store To. All the Programs within the Bank will be displayed in a list. 
2. Click on the required Program to overwrite it. Notice that the asterisk disappears, 

indicating that the Program no longer has changes that require storing, and that the 
newly stored Program is now selected.

To permanently keep Banks and Programs you have created, you will need to save them as 
files. Banks can be saved in their entirety, or you can save individual Programs from within a 
Bank. When Resound is closed, any unsaved changes to a Bank will be lost. 

To save an entire Bank to a file:

1. Under the File menu, choose Save Bank...
2. Choose a location and enter a filename for the Bank.

To save a Program to a file:

1. Select the Program you want to save
2. Under the File menu, choose Save Program...
3. Choose a location and enter a filename for the Program.

To load a saved Bank from a file:

1. Under the File menu, choose Open... 
2. Browse to the location and select the required Bank file.

Program Management
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To load a saved Program from a file:

1. Decide where in the Bank you want the Program to be loaded.
2. Select this Program.
3. Under the File menu, choose Open...
4. Browse to the location and select the required Program file

Create a new Bank

Select New Bank, under the File menu, to create a new Bank. All Programs within the Bank 
will be in their initialized state.

Create a new Program

Select New Program, under the File menu, to create a new Program. This Program will be 
in its initialized state.

Compare a changed Program to the original Program

Often you’ll want to compare a Program that you have amended to see if it is is actually an 
improvement on the original. Pressing the A | B button temporarily reverts a changed 
Program back to its original state. Pressing the A | B button a second time returns to the 
changed Program. This method allows you to easily contrast the Program changes you have 
made to the original Program.

Program Management
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MIDI Controller Mapping

MIDI controllers

Instead of configuring a Program using a mouse, you can change any Parameter values 
using a MIDI keyboard or a control surface. This is done by mapping each Parameter to a 
MIDI Continuous Controller (CC). A Parameter can only be mapped to a single MIDI 
controller; the same MIDI control can, however, be mapped to several different Parameters.  

MIDI Controller mappings are global; once defined, the same mapping assignments will be 
used by all Resound Programs. This means that you only need define mappings once for 
your particular controller.

Display current MIDI controller mappings

To view the current MIDI controller mappings:

1. Enter MIDI Learn Mode by choosing Start MIDI Learn under the Options menu. Each 
Parameter's mapped MIDI controller will now be displayed beside it in yellow text. 
Parameters without any mapping will be labelled -.  

2. When you have finished viewing the MIDI controller mappings, choose Stop MIDI Learn 
under the Options menu. 

Assign MIDI controllers to controls

To map a MIDI controller to a Parameter:

1. Enter MIDI Learn Mode by choosing Start MIDI Learn under the Options menu. 
2. Click on the Parameter you wish to map to a MIDI controller.
3. Turn your MIDI controller. The Parameter should now be labelled with the MIDI CC 

number of this controller. 
4. You can now either:

• Map another Parameter by repeating these steps from Step 2.
• Finish mapping Parameters by choosing Stop MIDI Learn under the Options menu.

MIDI Controller Mapping
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Remove MIDI controller mappings from controls

To remove a mapped  MIDI controller from a Parameter:

1. Enter MIDI Learn Mode by choosing Start MIDI Learn under the Options menu. 
2. Click on the Parameter from which you wish to remove the mapping. This Parameter will 

become unmapped, and the CC number label on the Parameter will disappear to reflect 
this.

3. You can now either:

• Remove the mapping from another Parameter by repeating these steps from Step 2.
• Finish removing Parameter mappings by choosing Stop MIDI Learn under the 

Options menu.

MIDI Controller Mapping
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Using Resound

Resound can be used as either an insert or send effect. When used as an insert effect, 
Resound is placed directly in a host's audio channel. As a send effect, Resound is placed in a 
host's auxiliary or bus channel, and a portion of the original signal is fed into the effect. 
Consult your host's documentation to find out how to add a plug-in as either an insert or as a 
send effect. 

Parameters

• The Noise Parameter introduces instability and hiss into the delay. These additions imitate 
the imperfections present in tape-based delay units and so produce a more convincing 
retro sound.

• The Time Parameter controls the length of time between repeats. When Sync is turned on, 
the delay time is based upon musical note divisions and will be in step with the host tempo. 
With Sync off, the time delay is expressed in milliseconds. A characteristic effect, often used 
in tape-based delay units, is the pitch shifted delay; this is achieved by sweeping the Time 
Parameter value upwards or downwards.

• The Feedback Parameter controls the proportion of the signal to be fed back into the delay 
line. As the value increases, the delayed signals volume will increase. At higher values, it is 
possible to create a wall of sound using delays that don't decrease in volume when they are 
fed back into the delay line. Beyond this, it is even possible to create delays that increase in 
volume. Warning: High Feedback settings can produce dangerously loud signals that can 
damage both your ears and audio equipment.

• Using the Highpass Parameter, the amount of low frequency content fed back into the 
delay line can be changed. More low frequency content is removed as the Highpass value 
increases. 

• The Sync Parameter switches the Time Parameter between two modes of operation: when 
Sync is off, the delay time is independent of the host tempo; when Sync is on, the Time 
Parameter is controlled by the host tempo. See Time Parameter.

• Enabling Reverse will cause the delayed signal to be played backwards. 

• The Mix controls the relative volumes of the original (dry) and delayed (wet) signal. At 0%, 
only the dry signal is present; at 100% only the wet signal will be heard. At 50%, the dry 
and wet signals will be heard in equal amounts. A 100% wet signal is useful when Resound 
is being used as send/return effect and you don't want any of the original signal to be 
heard.

Using Resound
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• The Volume Parameter governs the overall loudness of the effect. A meter provides a visual 
cue to the current level: the louder the output, the higher the meter will register. Too loud of 
an output will produce digital clipping, a usually undesirable form of distortion. When this 
occurs, the meter will display a red warning indicator. Click the meter to reset the warning 
display.

Control types

• Click on a rotary control and drag either upwards to increase the value, or downwards to 
decrease it. Hold down shift and drag to make smaller and more precise changes. Hold 
down ctrl and click to return the control to its default value. Rotary controls can also be 
changed by hovering the mouse cursor over a rotary control and scrolling the mouse-wheel 
up or down.

• Click on a button control to toggle its value between On and Off. Hold down ctrl and click 
to return the control to its default value.

Using Resound
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Status Display

Status Display information is displayed at the bottom right area of the Resound interface:

CPU Usage monitor

The CPU Usage monitor displays the percentage of processor resources dedicated to 
producing the audio output. The total processor resources on a computer are limited, so 
when Resound increases its CPU usage, there will be less CPU resources remaining for other 
plug-ins and applications. CPU Usage will differ depending on which Program is currently 
loaded, how that particular Program is configured, and how many voices are being played. 

A value of 100% indicates that your computer is running at maximum capacity and will not 
have enough processing power remaining for anything else. You might notice audio output 
become temporarily glitchy, or that the user interface becomes sluggish. There are several 
methods for resolving this:

• Choose a different Program that has less CPU Usage.
• If running in Standalone mode, you can increase the latency or decrease the sample rate. 

See section Setup Audio & MIDI.
• If your host offers Freeze or Offline processing, you might be able to render the audio 

output in non-realtime. 

MIDI input monitor

The MIDI monitor flickers to show that a MIDI Message has been received. You can use this 
to confirm that your MIDI controller is configured correctly for Resound.

Tempo control

The Tempo control only appears when running Resound in Standalone mode; when running 
as a plug-in, the host application will provide the tempo for Resound. The Tempo control 
displays the current Tempo, in beats per minute (bpm). It can be changed by either:

• Double-clicking the tempo control, typing the required bpm and pressing return.
• Clicking on the tempo control and dragging either upwards to increase the tempo, or 

downwards to decrease the tempo.

Status Display
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